Call quality issues with 1300 85 88 19 support number
Incident Report for Powernet IT Solutions
Resolved
This incident has been resolved.
Posted Jan 16, 2020 - 11:32 AEDT
Update
Service Desk wishes to advise that we continue to experience call quality issues with our 1300 85 88 19 support line. This issue is actively being investigated. Please bare with us while we work through the call quality issues.

End users requiring phone support continue to be advised to call our main support line - 03 9927 6000 -which is operasting normally.
Posted Dec 03, 2019 - 14:31 AEDT
Identified
Service Desk wishes to advise that we are currently experiencing call quality issues with the 1300 85 88 19 support number. End users requiring phone support are advised to call our main support line - 03 9927 6000 -which is operasting normally.
Posted Nov 25, 2019 - 11:23 AEDT
This incident affected: Service Desk (Phone System).