Global Microsoft Teams outage affecting phone system
Incident Report for Powernet IT Solutions
Resolved
This incident has been resolved.
Posted Jul 21, 2022 - 17:47 AEST
Update
Issue is now resolved
Posted Jul 21, 2022 - 17:46 AEST
Update
We are continuing to investigate this issue.
Posted Jul 21, 2022 - 17:44 AEST
Update
We are continuing to investigate this issue.
Posted Jul 21, 2022 - 17:44 AEST
Investigating
Hi,

There is a known Global Outage with Microsoft Teams. Microsoft is investigating this as we speak.

As a result, Powernet's phone lines are not reachable.

Please use HelpHub or email us on support@power-net.com.au for any support enquiries during this time.

There is no solution ETA from Microsoft at of this moment for this issue.

Thank you,

Powernet IT Solutions
Posted Jul 21, 2022 - 12:10 AEST
This incident affected: Service Desk (Phone System) and Third Party Providers (Microsoft Office 365).