Microsoft 365 Service Disruption
Incident Report for Powernet IT Solutions
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 07:02 AEST
Identified
Microsoft have advised that they are currently experiencing a disruption to their Microsoft 365 platform. Users may receive an error when attempting to access Microsoft 365 services. Microsoft is aware of the issue and is working on a resolution. Further updates will follow as new / additional information becomes available.
Posted Jun 15, 2020 - 09:58 AEST
This incident affected: Third Party Providers (Microsoft Office 365).