Microsoft 365 Service Outage
Incident Report for Powernet IT Solutions
Resolved
From Microsoft - Update on Microsoft 365 service disruption

Microsoft has taken additional actions to remediate the residual impact to customers hosted in North America and their monitoring indicates that service health has been restored for all regions. Microsoft continues to monitor to ensure the issue is fully resolved.
Posted Sep 29, 2020 - 14:53 AEST
Update
We are continuing to monitor for any further issues.
Posted Sep 29, 2020 - 14:52 AEST
Update
Microsoft 365 Service health status

Microsoft have confirmed via their monitoring that the majority of services have recovered for most customers. However, Microsoft continues to see a small subset of customers whose tenants are located in North America region who are still impacted.

Microsoft is investigating mitigation steps for those customers who are still affected.
Posted Sep 29, 2020 - 13:22 AEST
Monitoring
Microsoft has advised their mitigation strategy was successful in allowing users to sign into the previously impacted services. Microsoft's internal monitoring has validated this recovery and they have received positive confirmation from customer reports. Microsoft will continue to monitor the service and provide updates on full recovery to remaining impacted users.
Posted Sep 29, 2020 - 11:08 AEST
Update
From Microsoft - Update on Microsoft 365 service disruption

Current status: We’ve determined that a specific portion of our infrastructure is not processing authentication requests in a timely manner. We’re pursuing mitigation steps for this issue. In parallel, we’re rerouting traffic to alternate systems to provide further relief to the affected users.

Scope of impact: Any user may experience access problems for Microsoft 365 services
Posted Sep 29, 2020 - 10:57 AEST
Identified
Microsoft have advised that there is currently an incident affecting Microsoft 365 services. Users may be unable to access multiple Microsoft 365 services.

Users would be unable to access Outlook.com. Microsoft Teams including Teams Live Events, and Office.com. Additionally, Power Platform and Dynamics365 properties are affected by this incident.

Existing customer sessions are not impacted and any user who is logged in to an existing session would be able to continue their sessions.

Microsoft is currently investigating this issue - further updates will be provided as new information becomes available.
Posted Sep 29, 2020 - 10:06 AEST
This incident affected: Third Party Providers (Microsoft Office 365).