Microsoft 365 Outage - Services may be affected
Incident Report for Powernet IT Solutions
Resolved
This incident has been resolved.
Posted Feb 07, 2022 - 14:21 AEDT
Update
We are continuing to investigate this issue.
Posted Feb 07, 2022 - 14:20 AEDT
Investigating
Dear Clients,

We have just been made aware of a Microsoft 365 outage which may cause disruptions to M365 applications. Microsoft are currently investigating and working on a resolution. We will continue to update you as we receive further information. We will also be sending out a Broadcast in Help Hub.
Posted Dec 16, 2021 - 13:17 AEDT