Microsoft Authentication Issues
Incident Report for Powernet IT Solutions
Resolved
This incident has been resolved.
Posted Aug 02, 2021 - 19:02 AEST
Monitoring
We have reports the issue is now remediated. If you are still experiencing issues, please restart your device/s and log in again. If the issue still persists please contact us on 1300 892 692.
Posted Aug 02, 2021 - 11:26 AEST
Investigating
There are current issues with Microsoft Authentication causing disruptions to users. You may be experiencing access your Microsoft products including email. We are monitoring the situation closely and will provide update as the information from Microsoft progresses.
Posted Aug 02, 2021 - 10:17 AEST
This incident affected: Third Party Providers (Microsoft Office 365).