New Release of the IT App
Incident Report for Powernet IT Solutions
Resolved
This incident has been resolved.
Posted Aug 15, 2019 - 18:35 AEST
Identified
The latest release of the IT App is now available for release to our customers. As part of the deployment, the existing desktop IT App will be removed from end user devices and replaced with the latest release (v2.4). Our deployment tools will then automatically deploy the latest release of the IT App. Please note that end user devices MUST be restarted once the IT App is removed, in order to allow the new version of the IT App to be installed.

Whilst the new version of the IT App is being rolled out, all end users can continue to log and monitor service tickets via the IT App Web Portal - https://power-net.deskdirector.com/portal/v2/login?redirectUrl=%2Flanding-page.
Posted Jul 25, 2019 - 14:09 AEST
This incident affected: Service Desk (Powernet IT App).