Hosted Exchange interruptions
Incident Report for PowerNET IT Solutions
Resolved
The root cause issue was resolved as of Sunday, and all interruptions experienced from this have been confirmed as fixed.
Posted Nov 22, 2017 - 07:43 AEDT
Identified
We have identified some customers being affected by temporary issues with Hosted Exchange
The Vendor has confirmed the issue, and is working to resolve this.
In the meantime, OWA (webmail access) is an appropriate workaround - https://mail.aus.exch690.serverdata.net/
You can log in with your usual credentials.
It is worth closing Outlook for the time being as resource usage may be high.
Posted Nov 17, 2017 - 14:37 AEDT