PowerNET Inbound Calls - QLD
Incident Report for PowerNET IT Solutions
Resolved
This incident has been resolved.
Posted almost 2 years ago. Sep 05, 2017 - 13:12 AEST
Identified
We are currently experiencing issues with inbound calls via our Queensland inbound number. Our telephone provider is currently investigating.

If you have an urgent matter please call in on our Melbourne number of (03)9927-6000, otherwise please email support@power-net.com.au to log a ticket.
Posted over 2 years ago. Mar 03, 2017 - 10:36 AEDT