Microsoft Office 365 - Exchange Online - Partial Outage
Incident Report for PowerNET IT Solutions
Resolved
This incident has been resolved.
Posted May 22, 2019 - 12:33 AEST
Update
We are continuing to investigate this issue.
Posted May 22, 2019 - 12:33 AEST
Investigating
Microsoft has advised that their is currently a partial outage affecting their Exchange Online (e-mail) service. End users may not be able to connect to their mailbox via an e-mail client (Outlook) nor webmail (Outlook Web App). Microsoft is aware of the issue and their engineering team is working on a resolution. Further updates will be provided as we receive new information from Microsoft.
Posted May 22, 2019 - 11:14 AEST